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1 はじめに 

 

本書は、産業技術総合研究所 創薬分子プロファイリング研究センターにて運用する統合 DB

情報基盤サイトで公開している解析サービスの「Active ワークフロー」のうち、組み合わせ

型について、使用方法を記述したユーザーマニュアルです。 

 

Active ワークフローのインストール方法については別途、インストールマニュアルをご参照

いただき、併せて統合 DB情報基盤サイト Web サイトをご利用ください。 

 

統合 DB情報基盤サイト ： http://togo.medals.jp/ 

 

Active ワークフローは、KNIME上で実行します。 

操作方法は、KNIMEに準じているため、本ユーザーマニュアルでは、Active ワークフロー

の実行についての説明を記しています。 

KNIMEについては、以下のサイトをご参照ください。 

 

KNIME ：http://www.knime.org/ 

 

  

http://togo.medals.jp/
http://www.knime.org/
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2 Activeワークフロー組み合わせ型について 

 

Active ワークフロー組み合わせ型は、現在下表の 4種類です。 

 

2-1 Active ワークフロー組み合わせ型一覧 

No. Active ワークフロー組み合

わせ型 名称 

対応 OS 説明 

1 RNA Structure Prediction 

Active Workflow 

Windows32bit 

Linux 64bit 

MacOS (OS X 

10.7以上) 

RNAの構造予測を行う

ワークフロー 

2 Protein Structure 

Prediction Active 

Workflow 

Windows32bit 

Linux 64bit 

MacOS (OS X 

10.7以上) 

モデリング、ディスオー

ダー領域予測、細胞内局

在予測、翻訳後修飾予

測、タンパク質機能予測

等を行うワークフロー 

3 PhylogeneticTree Active 

Workflow 

Windows32bit 

Linux 64bit 

MacOS (OS X 

10.7以上) 

マルチプルアライメン

ト、系統樹作成を行うワ

ークフロー 

4 Molecular Simulation 

Active Workflow 

Windows32bit 

Linux 64bit 

MacOS (OS X 

10.7以上) 

分子シミュレーション

(タンパク質構造のモデ

リング、ドッキング計

算、エネルギー最小化計

算、分子力場計算 

(MM)、分子動力学計算

(MD) )を行うワークフ

ロー 
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3 Activeワークフロー基本ルール 

 

すべての Active ワークフローに共通するルールは下記のとおりです。 

 

1. ワークフローの起動 

起動後の KNIME 画面の左上にある Workflow Projects 欄で、使用する Active ワークフ

ローをダブルクリックすることで、中央欄に Active ワークフローが表示され、使用可能

となります。 

 

3-1 例.RNA_Structure_Prediction ワークフローの起動 

 

2. ノード 

Active ワークフロー画面に表示される、各フローの基点となるものを、ノードと呼びま

す。 

 

3-2 例. ノード(FastaFileReader) 

 

各ノードについての説明は、ノード選択時、KNIME画面の右側にある「Node 

Description」欄に表示されます。  



 

4 

 

3. ノード進捗表示 

ノードの下方にある信号機のマークは、右端の緑色表示時は実行完了を現し、黄色は実

行準備が整った待機状態を現し、赤は実行準備中を現します。 

実行中のノードは、濃い青色のバーが動き実行中であることを現します。 

 

3-3ノード進捗表示一覧 

ノード進捗表示 表示色 進捗内容 

 
赤色 実行準備中 

 
黄色 実行準備完了、待機中 

 緑色 実行完了 

 
濃青色 実行中 

 queued 待機中 

 

4. ノードの設定 

ノードを選択した状態で、右クリックを押下することで、ノードの設定、またはノード

の動作を指示します。 

主なメニューコマンドとその内容は以下のとおりです。 

 

 

3-4 右クリックメニュー 
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3-5表示メニューコマンド一覧 

コマンド名 内容 特記事項 

Configure… ノードの各種設定を行う

際に使用します。 

別ウインドウを起動し

ます。 

Execute ノードを実行します。 ノード進捗状態表示色

が黄色以外は、グレーで

表示され、使用できませ

ん。 

Execute and Open Views 結果画面表示を行うノー

ドの場合、アクティブ表示

となり、ノードを実行する

際に使用します。 

ノード進捗状態表示色

が黄色、かつ、結果画面

表示を行うノード以外

は、グレーで表示され、

使用できません。 

Cancel 実行中のノードに対し、実

行をキャンセルする際に

使用します。 

ノード進捗状態表示色

が濃青色の実行中のノ

ード以外は、グレー表示

され、使用できません。 

Reset 設定をリセットします。 ノード進捗状態表示が

実行完了(緑色)の場合

に、アクティブ表示とな

ります。 

Edit Node Name and 

Description… 

ノード名の変更や、

Description の追記を行う

場合に使用します。 

別ウインドウを起動し

ます。 

New Workflow Annotation ワークフロー内にコメン

トを挿入します。 

コメント欄を表示しま

す。 

View : [viewer name] ノードの実行結果画面表

示を行うノードの場合に、

アクティブ表示となり、結

果画面参照する際に使用

します。 

ノードの実行結果画面

表示を行うノード以外

は、グレーで表示され、

使用できません。 

別ウインドウを起動し

ます。 

Cut ノード、コメント等をカッ

トします。 

特になし 

Copy ノード、コメント等をコピ

ーします。 

特になし 
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Paste ノード、コメント等がコピ

ーされている場合に、貼り

付けます。 

特になし 

Undo ノード、コメント等の

Cut/Copy/Paste 等の直前

の作業を取り消します。 

特になし 

Redo Undoを使用し取り消した

作業を、元に戻します。 

特になし 

Delete ノード、コメント等を削除

します。 

特になし 

 

5. ノード一括実行 

Active ワークフローの設定が必要なノード全てに設定が終わった場合に、一括して実行

を行うことが可能です。 

その場合は、起点となるノードを選択した上で、KNIME画面の上部にあるアイコンを

クリックしてください。(Execute all executable nodes (Shift+F7)) 

 

3-5 一括実行 

 

6. アラートメッセージとエラーメッセージ 

 

ノードを実行し、アラート発生やエラー発生時には、ポップアップ画面で表示され、ま

た、KNIME画面右下の Console 欄に表示されます。 

アラートメッセージとエラーメッセージは、その解決方法を示唆します。 

実行に失敗した場合は、各メッセージを読むことで解決へつながります。 

以下にメッセージ例と解決方法を示します。 

 

3-6メッセージ一覧 

No メッセージ 原因と解決方法 

1 Console メッセージ： 

WARN   FastaFileReader 0:2:1  

failed to apply settings: Please specify 

a filename. 

原因： 

 ファイルを指定していません。 

解決方法： 

 ファイルを指定してください。 

2 ポップアップメッセージ： 

SOAP execution error. 

Please resubmit again later. 

原因： 

SOAP実行時のエラーです。 

SOAP通信でエラーが発生して
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Console メッセージ： 

ERROR CentroidFold_AIST Execute 

failed: Error occurred. 

いる場合があります。 

解決方法： 

時間をおいて再実行してくださ

い。 
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4 RNA Structure Predicitonの使用方法 

 

RNA_Structure_Prediction は、RNAの構造予測等を行うワークフローです。 

 

 

4-1 RNA_Structure_Prediction ワークフロー 

 

4.1 実行準備 

 

実行に必要なファイルは、FASTAフォーマットの配列ファイルです。 

 

ファイルタイプ 

FASTA フォーマットファイル 
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4.2 ノード 

 

RNA_Structure_Prediction Active Workflow のノードは複数種類存在します。 

ノードは、実行環境の設定が必要な場合があります。 

ノード一覧と、ノードの実行環境設定は以下のとおりです。 

使用するツリーのノードに応じて、設定を行ってください。 

 

4.2.1 ノード一覧 

 

以下の 17種類です。 

 

4.2.1-1 RNA_Structure_Prediction Active Workflow のノード一覧 

No 名前 アイコン 設

定 

説明 

1 SetVariable 

 

要 CASE Switch 

Variable を操作

する。ダイアロ

グ画面で 0、1、

2を設定すると

CASE Switchの

第一アウトポー

トに、1を設定す

ると第二アウト

ポートにフロー

が流れる。 

2 CASE Switch 

Variable(Start) 

 

 CASE Switchを

行う KNIMEノ

ード。 
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3 FastaFileReader 

 

要 FASTAフォー

マットファイル

を読み込みま

す。 

4 LSDBCrossSearch 

 

- 生命科学データ

ベース横断検索

を表示します。 

5 Sparql_AIST 

 

要 AISTで公開さ

れている

SPARQLエンド

ポイントに対し

て SPARQL検

索を実行しま

す。 

6 SequenceSelector 

 

 SPARQL検索で

取得した配列を

選択します。 

7 CASE Switch 

Variable (End) 

 

 CASE Switchの

エンドノード。 

8 CentroidFold_AIST 

 

要 CentroidFold を

実行します。 
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9 IPknot_AIST 

 

要 IPknotを実行し

ます。 

10 RNA2DChecker_AIST 

 

 RNA2DChecker

を実行します。 

11 RASSIE_AIST 

 

要 RASSIEを実行

します。 

12 RactIP_AIST 

 

要 RactIPを実行し

ます。 

13 Rascal_AIST 

 

要 Rascalを実行し

ます。 

14 Sparql_AIST_Adv 

 

要 公開されている

SPARQLエンド

ポイントに対し

て SPARQL検

索を実行しま

す。 

1 5 AISTViewer 

 

 予測結果を表示

します。 

※ビューア表示

はそれぞれ異な

ります。 
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16 HtmlView 

 

 予測結果を表示

します。 

※ビューア表示

はそれぞれ異な

ります。 

17 JmolForModeller 

 

 Jmolを起動しま

す。 
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4.2.2 ノード実行環境設定 

4.2.2.1 SetVariable 

 

CASE Switch Variable (Start)ノードの出力ポートを切り替えます。 

 

1) SetVariable ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

 

4.2.2.1-1 SetVariable ：Configure… 

 

0、1、2の 3つの数字が CASE Switch Variable(Start)ノードの 1～3番目

の出力ポートにそれぞれ対応しております。 FastaFileReaderを使う場合は 0

を、Sparql_AISTを使う場合は 1を指定します。 

  指定後、[Apply]ボタン、[OK] ボタンを押下します。 
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4.2.2.2 FastaFileReader 

 

実行に使用する RNAの FASTAファイルを指定します。 

 

1) FastaFileReader ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

 

4.2.2.2-1 FastaFileReader ：Configure… 

 

・Options タブ → Fasta File → SelectedFile: 

図の赤枠内に、実行に使用するFASTAフォーマットファイルを入力します。 

  [Browse…] ボタンを押下し、ファイル選択画面を開き、実行に使用する

FASTA フォーマットファイルを選択することも可能です。 

 指定後、[OK] ボタンを押下します。 
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4.2.2.3 Sparql_AIST 

 

AISTで公開されている SPARQLエンドポイントに対して SPARQL検索を行い

ます。 

 

1) Sparql_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

   

4.2.2.3-1 Sparql_AIST ：Configure… 
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・Options タブ → Output → Selected Directory: 

Sparql_AIST の実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

・Options タブ → SPARQL endpoints: 

SEVENS、fRNAdb、UNIPROT、PDB、KEGG-pathway の 5つのエンド

ポイントをチェックボックスで選択します。本ワークフローでは fRNAdbをチ

ェックします。 

 

・Options タブ → SPARQL search conditions: 

タクソン(Taxon)、キーワード(Keyword)、最小配列長(Minimum)、最大配

列長(Maximum)、解像度(Resolution)、パスウェイ(Pathway)を指定します。

本ワークフローではキーワード、最小配列長、最大配列長が有効です。 

 

・Options タブ → Output format: 

FASTA または Tab-delimited のラジオボタンを指定します。 

 

 

指定後、[OK] ボタンを押下します。 
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4.2.2.4 CentroidFold_AIST 

 

出力ディレクトリと CentroidFold の実行パラメータ設定を行います。 

 

1) CentroidFold_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

   

4.2.2.4-1 CentroidFold_AIST ：Configure… 

 

・Options タブ → Input type → Format 

このノードの入力に使用するファイルフォーマットを、ラジオボタンで選択

します。 

 

・Options タブ → Output → Selected Directory: 

CentroidFold_AIST の実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 
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・Options タブ → Weight of base pairs → Gamma: 

CentroidFold_AIST の実行パラメータを変更します。 

プルダウンメニューより、パラメータを変更してください。 

デフォルトでは、「2^2」が設定されています。 

 

・Options タブ → Advanced → Other options 

CentroidFold_AIST の gamma 以外の実行パラメータを設定します。 

デフォルトでは、何も設定されていません。 

 

指定後、[OK] ボタンを押下します。 

 

4.2.2.5 IPknot_AIST 

 

出力ディレクトリの設定を行います。 

 

1) IPknot_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面を使用します。 

 

4.2.2.5-1 IPknot_AIST ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 
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  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

指定後、[OK] ボタンを押下します。 

 

4.2.2.6 RactIP_AIST 

 

出力ディレクトリの設定を行います。 

 

1) RactIP_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面を使用します。 

  

4.2.2.6-1 RactIP_AIST ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

指定後、[OK] ボタンを押下します。 
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4.2.2.7 Rascal_AIST 

 

1) Rascal_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面を使用します。 

  

4.2.2.7-1 Rascal_AIST ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

・Options タブ → Advanced: 

Rascalに対するオプションを指定します。使用する場合はチェックボック

スをチェックします。 

 

指定後、[OK] ボタンを押下します。 
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4.2.2.8 RASSIE_AIST 

 

出力ディレクトリの設定を行います。 

 

1) RASSIE_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面を使用します。 

  

4.2.2.8-1 RASSIE_AIST ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

指定後、[OK] ボタンを押下します。 
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4.3 実行と結果参照 

4.3.1 IPknot_AIST 

 

1) HtmlView 

 

IPknot_AISTの実行結果は、HtmlView を実行することで、参照することができま

す。 

IPknot の実行結果は、テキスト表示されます。 

 

 

  

4.3.1-1 HtmlView– IPknot Results 
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4.3.2 RactIP_AIST 

 

1) HtmlView 

 

RactIP_AISTの実行結果は、HtmlView を実行することで、参照することができ

ます。 

RactIP の実行結果は、テキスト表示されます。 

 

  

4.3.2-1 HtmlView– RactIP Results 
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4.3.3 Rascal_AIST 

 

1) JmolForModeller 

 

Rascal_AISTの実行結果は、JmolForModeller を実行することで、立体構造をモ

デリングした結果を参照することができます。 

 

Jmolの詳細については、下記のサイトを参照してください。 

Jmol ：http://jmol.sourceforge.net/ 

 

 

 

4.3.3-1 JmolForModeller –Results 

 

Results は、Jmolを利用して、モデリング結果の立体構造を表示します。 

Jmolで参照したい結果をラジオボタンで選択し、下部の [ Execute Jmol ] ボタンを押

下します。Jmolが起動し、選択したモデリング結果の立体構造が表示されます。 

右下の Jmol文字列をクリックすることで、Jmolのメニューが表示されます。 

Jmolの操作方法は下記を参照してください。 

Jmol ：http://jmol.sourceforge.net/ 

  

http://jmol.sourceforge.net/
http://jmol.sourceforge.net/
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4.3.4 RASSIE_AIST 

 

1) JmolForModeller 

 

RASSIE_AISTの実行結果は、JmolForModellerを実行することで、立体構造をモ

デリングした結果を参照することができます。 

 

Jmolの詳細については、下記のサイトを参照してください。 

Jmol ：http://jmol.sourceforge.net/ 

 

 

 

4.3.4-1 JmolForModeller –Results 

 

Results は、Jmolを利用して、モデリング結果の立体構造を表示します。 

Jmolで参照したい結果をラジオボタンで選択し、下部の [ Execute Jmol ] ボタンを押

下します。Jmolが起動し、選択したモデリング結果の立体構造が表示されます。 

右下の Jmol文字列をクリックすることで、Jmolのメニューが表示されます。 

Jmolの操作方法は下記を参照してください。 

Jmol ：http://jmol.sourceforge.net/ 

 

  

http://jmol.sourceforge.net/
http://jmol.sourceforge.net/


 

26 

 

 

4.3.5 CentroidFold_AIST 

 

1) AISTViewer 

AISTViewer で CentroidFold_AISTの実行結果を参照することができます。 

予測された 2次構造をクリックすることで、拡大図が別画面で表示されます。 

 

  

4.3.5-1 AISTViewer – CentroidFold Results 

 

 

  



 

27 

 

5 Protein Structure Predictionの使用方法 

 

Protein Structure Prediction Active ワークフローは、モデリングやディスオーダー予測等

を行うワークフローです。 

 

モデリングは、SOAP通信を用いてタンパク質の立体構造モデリングを行います。 

まず、ユーザが用意した問い合わせ配列に対し、既存の立体構造のアミノ酸配列(PDB 

(http://www.rcsb.org/)エントリファイルの ATOM行から生成したアミノ酸配列) との類似領

域を BLAST、PSI-BLASTを用いて選定します。次に、期待値、アミノ酸一致度、ヒット領

域の割合を基準として、各問い合わせ配列のヒット領域に対して最適と考えられる立体構造を

選定し、高い類似性を示す領域には PDBｊ Mine Web 

(http://service.pdbj.org/mine/index_j.html) に登録された立体構造情報を、それ以外の領域に

ついては MODELLER (http://salilab.org/modeller/)を用いたタンパク質立体構造の モデリ

ングを行います。モデリングされた立体構造は、Jmol (http://jmol.sourceforge.net/) によって

閲覧することができます。 

なお、MODELLER の実行にはライセンスキーが必要となりますので 、

http://salilab.org/modeller/registration.html より事前に取得してください。 

 

また、PSIPRED を用いたタンパク質の 2次構造予測の実行、Poodle、WolfPsort等タンパ

ク質の配列解析ソフトウェアの実行を一度に行うワークフローです。 

 

5-1 Protein_Structure_Prediction 

 

http://www.rcsb.org/
http://service.pdbj.org/mine/index_j.html
http://salilab.org/modeller/
http://jmol.sourceforge.net/
http://salilab.org/modeller/registration.html
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5.1 実行準備 

 

実行に必要なファイルは、FASTAフォーマットのアミノ酸配列ファイルです。 

※ FASTAフォーマットをつなげた、Multi-Fastaフォーマットファイルは

利用できません。 

 

ファイルタイプ 

FASTA フォーマットアミノ酸配列ファイル 

 

5.2 ノード 

 

Protein Structure Prediction Active Workflow のノードは複数種類存在します。 

ノードは、実行環境の設定が必要な場合があります。 

ノード一覧と、ノードの実行環境設定は以下のとおりです。 

使用するツリーのノードに応じて、設定を行ってください。 

 

5.2.1 ノード一覧 

 

以下の 34種類です。 

 

5.2.1-1 Protein_Structure_Prediction Active Workflow のノード一覧 

No 名前 アイコン 設

定 

説明 

1 SetVariable 

 

要 CASE Switch 

Variable を操作

する。ダイアロ

グ画面で 0、1、

2を設定すると

CASE Switchの

第一アウトポー

トに、1を設定す

ると第二アウト

ポートにフロー

が流れる。 
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2 CASE Switch 

Variable(Start) 

 

 CASE Switchを

行う KNIMEノ

ード。 

3 FastaFileReader 

 

要 FASTAフォー

マットファイル

を読み込みま

す。 

4 LSDBCrossSearch 

 

- 生命科学データ

ベース横断検索

を表示します。 

5 Sparql_AIST 

 

要 AISTで公開さ

れている

SPARQLエンド

ポイントに対し

て SPARQL検

索を実行しま

す。 

6 SequenceSelector 

 

 SPARQL検索で

取得した配列を

選択します。 

7 CASE Switch 

Variable (End) 

 

 CASE Switchの

エンドノード。 
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8 BlastForModeller_AIST 

 

要 BLASTもしくは

PSI-BLASTを実行

します。 

9 HitRegionSelector_AIST 

 

要 BLASTもしくは

PSI-BLASTの実行

結果より、立体構造

ヒット領域を抽出

します。 

10 TemplateSelector_AIST 

 

要 立体構造モデリン

グのテンプレート

を選択します。 

1 1 Modeller_AIST 

 

要 MODELLER を実

行します。 

12 CPHmodels_DTU 

 

要 ホモロジーモデリ

ングを実行します。 

13 PsiPred_AIST 

 

要 PsiPredを実行しま

す。 

14 Poodle_AIST 

 

要 POODLE を実行し

ます。 
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15 TmHmm_DTU 

 

要 TMHMMを実行し

ます。 

16 SignalP_DTU 

 

要 SignalPを実行しま

す。 

17 ChloroP_DTU 

 

要 ChloroPを実行し

ます。 

18 LipoP_DTU 

 

要 LipoPを実行しま

す。 

19 NetCTL_DTU 

 

要 NetCTLを実行し

ます。 

20 NetChop_DTU 

 

要 NetChop を実行し

ます。 

21 NetNES_DTU 

 

要 NetNESを実行し

ます。 
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22 NetPhosK_DTU 

 

要 NetPhosK を実行

します。 

23 NetPhos_DTU 

 

要 NetPhosを実行し

ます。 

24 NetPicoRNA_DTU 

 

要 NetPicoRNA を実

行します。 

25 DictyOGlyc_DTU 

 

要 DictyOGlyc を実行

します。 

26 WolfPsort_AIST 

 

要 WoLF PSORTを実

行します。 

2 7 TargetP_AIST 

 

要 TargetPを実行し

ます。 

28 SecretomeP_DTU 

 

要 SecretomePを実行

します。 
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29 DisoPred_AIST 

 

要 DISOPRED を実行

します。 

30 Memsat_AIST 

 

要 MEMSATを実行し

ます。 

31 Sparql_AIST_Adv 

 

要 公開されている

SPARQLエンドポ

イントに対して

SPARQL検索を実

行します。 

32 AISTViewer 

 

 予測結果を表示し

ます。 

※ビューア表示は

それぞれ異なりま

す。 

33 HtmlView 

 

 予測結果を表示し

ます。 

※ビューア表示は

それぞれ異なりま

す。 

34 JmolForModeller 

 

 Jmolを起動しま

す。 
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5.2.2 ノード実行環境設定 

5.2.2.1 SetVariable 

 

CASE Switch Variable (Start)ノードの出力ポートを切り替えます。 

 

1) SetVariable ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

 

5.2.2.1-1 SetVariable ：Configure… 

 

0、1、2の 3つの数字が CASE Switch Variable(Start)ノードの 1～3番目

の出力ポートにそれぞれ対応しております。 FastaFileReaderを使う場合は 0

を、Sparql_AISTを使う場合は 1を指定します。 

  指定後、[Apply]ボタン、[OK] ボタンを押下します。 
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5.2.2.2 FastaFileReader 

 

実行に使用するタンパク質の FASTAファイルを指定します。 

 

1) FastaFileReader ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

 

5.2.2.2-1 FastaFileReader ：Configure… 

 

・Options タブ → Fasta File → SelectedFile: 

図の赤枠内に、実行に使用するFASTAフォーマットファイルを入力します。 

  [Browse…] ボタンを押下し、ファイル選択画面を開き、実行に使用する

FASTA フォーマットファイルを選択することも可能です。 

 指定後、[OK] ボタンを押下します。 
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5.2.2.3 Sparql_AIST 

 

AISTで公開されている SPARQLエンドポイントに対して SPARQL検索を行い

ます。 

 

1) Sparql_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

   

5.2.2.3-1 Sparql_AIST ：Configure… 
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・Options タブ → Output → Selected Directory: 

Sparql_AIST の実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

・Options タブ → SPARQL endpoints: 

SEVENS、fRNAdb、UNIPROT、PDB、KEGG-pathway の 5つのエンド

ポイントをチェックボックスで選択します。本ワークフローでは SEVENS、

UNIPROT、PDBが有効となります。 

 

・Options タブ → SPARQL search conditions: 

タクソン(Taxon)、キーワード(Keyword)、最小配列長(Minimum)、最大配

列長(Maximum)、解像度(Resolution)、パスウェイ(Pathway)を指定します。

本ワークフローではタクソン、キーワード、最小配列長、最大配列長、解像度

が有効です。 

 

・Options タブ → Output format: 

FASTA または Tab-delimited のラジオボタンを指定します。 

 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.4 BlastForModeller _AIST 

 

プログラムの選択と出力ディレクトリの設定を行います。 

 

1) BlastForModeller_AIST ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

5.2.2.4-1 BlastForModeller_AIST ：Configure… 

 

・Options タブ → BLAST version 2.2.18 → Execution Type  

図の赤枠に、Execution Type をラジオボタンで選択します。 

Execution Type は、既存の立体構造のアミノ酸配列との相同性検索を行う

ためのプログラムを、BLASTもしくは PSI-BLAST から選択します。 

 

・Options タブ → BLAST version 2.2.18 → E-Value 

続いて、図の赤枠に、E-value を入力します。 

この E-Value は、BLAST もしくは PSI-BLAST検索において適用される期

待値の閾値となります。 

デフォルトでは、[ 1.0E-5 ] が設定されています。 
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・Options タブ → BLAST version 2.2.18 → Iteration 

続いて、図の赤枠に、Iteration を入力します。 

この Iteration は、PSI-BLASTの最大繰り返し検索回数です。なお、

Execution Type にて BLAST指定時は関与しません。 

デフォルトでは、[ 3 ] が設定されています。 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の青枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 

 

 

5.2.2.5 HitRegionSelector_AIST 

 

BLASTもしくは PSI-BLASTの結果ヒットした配列部の立体構造予測に使用する

条件を設定します。 

 

1) HitRegionSelector_AIST ノードを右クリックし、”Configure…” を選択しま

す。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

5.2.2.5-1 HitRegionSelector_AIST：Configure… 
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・Options タブ → Condition to select (PSI-)BLAST hit regions (Integer is 

only permitted to input) → Coverage(%) 

Coverage を設定します。 

Coverageは、ヒットした立体構造の全長に対するヒット領域の割合であり、

ヒットの基準閾値とするパーセンテージの値です。 

デフォルトでは、[ 60 ] が設定されています。 

 

・Options タブ → Condition to select (PSI-)BLAST hit regions (Integer is 

only permitted to input) → Identity(%) 

Identity を設定します。 

Identity は、ヒット領域間のアミノ酸の一致度であり、閾値とするパーセン

テージの値です。 

デフォルトでは、[ 30 ] が設定されています。 

 

・Options タブ → Condition to select (PSI-)BLAST hit regions (Integer is 

only permitted to input) → Minimum Length 

Minimum Length を設定します。 

Minimum Length は、ヒット領域の最小のアミノ酸長の値であり、閾値と

して使用します。 

デフォルトでは、[ 30 ] が設定されています。 

数値の入力制限は、以下のとおりです。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.6 TemplateSelector_AIST 

 

ヒット領域に対する立体構造モデリングのためのテンプレートを設定します。 

 

1) TemplateSelector_AIST ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

5.2.2.6-1 TemplateSelector_AIST：Configure… 

 

・Options タブ → Condition to determine for modelling or for displaying 

PDBj Mine Web. → Coverage(%), Identity(%) 

Coverate、Identity の値を設定します。 

Coverage は、ヒットした立体構造の全長に対するヒット領域の割合です。 

Identity は、ヒット領域間のアミノ酸の一致度です。 

この２つの値は、ヒットした立体構造と同様の構造を持つことの判定に用い

ます。指定した値を超えるヒット領域については、そのヒット領域はヒットし

た立体構造と同様であるとみなされ、PDBj Mine による立体構造情報表示の

処理に入ります。指定した値を満たさないヒット領域については、モデリング

のテンプレートとする立体構造を選択してモデリングの処理に入ります。 

デフォルト値は、Coverage 90 %、Identity 90 % です。 

整数値のみ入力が可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.7 Modeller_AIST 

 

MODELLER で生成するモデル数の最大値を設定と、MODELLER のライセンス

キーの入力を行います。 

 

1) Modeller_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

5.2.2.7-1 Modeller_AIST：Configure… 

 

・Options タブ → Condition for Modeller Execution → Number of Models 

for Modelling 

Number of Models for Modelling を入力します。 

Number of Models for Modelling は、MODELLER で生成するモデル数の

最大値として使用します。 

入力範囲は、 1～10 であり、整数値のみの入力が可能です。 

 

・Options タブ → Modeller License → License Key for Modeller 

(required) 

License Key for Modeller (required)では、MODELLER 実行のためのライ

センスキーを入力します。 

 

設定後、[OK] ボタンを押下します。 
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5.2.2.8 CPHmodels_DTU 

 

出力ディレクトリの設定を行います。 

 

1) CPHmodels_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.8-1 CPHmodels_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.9 PsiPred_AIST 

 

出力ディレクトリの設定を行います。 

 

1) PsiPred_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.9-1 PsiPred_AIST：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.10 Poodle_AIST 

 

POODLE のプログラム選択と出力ディレクトリの設定を行います。 

 

1) Poodle_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

 

5.2.2.10-1 Poodle_AIST ：Configure… 

 

・Options タブ → Type → POODLE Type 

実行する POODLEプログラムをラジオボタンで選択します。 

POODLE-Sは、短いディスオーダー領域を予測します。 

POODLE-Lは、40残基程度以上の長いディスオーダー領域を予測します。 

 

・Options タブ → Output → Selected Directory： 

Output欄に、実行結果を出力するディレクトリを入力します。 

 [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用

するディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.11 TmHmm_DTU 

 

出力ディレクトリの設定を行います。 

 

1) TmHmm_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.11-1 TmHmm_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.12 SignalP_DTU 

 

出力ディレクトリと”Organism type”の設定を行います。 

 

1) SignalP_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.12-1 SignalP_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

・Options タブ → Organism Type: 

 Eukaryotes、Gram-negative bacteria、Gram-positeve bacteria のどれか

一つを選択します。 

指定後、[OK] ボタンを押下します。 
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5.2.2.13 ChloroP_DTU 

 

出力ディレクトリの設定を行います。 

1) ChloroP_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.13-1 ChloroP_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.14 LipoP_DTU 

 

出力ディレクトリの設定を行います。 

 

1) LipoP_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.14-1 LipoP_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.15 NetCTL_DTU 

 

出力ディレクトリと”Supertype”の設定を行います。 

 

1) NetCTL_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.15-1 NetCTL_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

・Options タブ → Select Supertype: 

 A1~A3、A24、A26、B7、B8、B27、B39、B44、B58、B62から一つ選択

します。 

指定後、[OK] ボタンを押下します。 
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5.2.2.16 NetChop_DTU 

 

出力ディレクトリと”Prediction method”の設定を行います。 

1) NetChop_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.16-1 NetChop_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

・Options タブ → Select Prediction method: 

 C term 3.0、20S 3.0から一つ選択します。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.17 NetNES_DTU 

 

出力ディレクトリの設定を行います。 

 

1) NetNES_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.17-1 NetNES_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.18 NetPhosK_DTU 

 

出力ディレクトリの設定を行います。 

 

1) NetPhosK_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.18-1 NetPhosK_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.19 NetPhos_DTU 

 

出力ディレクトリの設定を行います。 

 

1) NetPhos_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.19-1 NetPhos_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.20 NetPicoRNA_DTU 

 

出力ディレクトリの設定を行います。 

 

1) NetPicoRNA_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.20-1 NetPicoRNA_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.21 DictyOGlyc_DTU 

 

出力ディレクトリの設定を行います。 

 

1) DictyOGlyc_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.21-1 DictyOGlyc_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.22 WolfPsort_AIST 

 

出力ディレクトリと生物界の設定を行います。 

 

1) WolfPsort_AISTノードを右クリックし、”Configure…” を選択します。 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

5.2.2.22-1 WolfPsort_AIST ：Configure… 

・Options タブ → Kingdom → Type 

図の赤枠の箇所に、ラジオボタンで animal, plant, fungi のどれか一つを選

択します。 

・Options タブ → Select Output Directory → Selected Directory: 

図の青枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.23 TargetP_DTU 

 

出力ディレクトリと”Organism type”の設定を行います。 

 

1) TargetP_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.23-1 TargetP_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

・Options タブ → Organism type: 

 Non-Plant、Plantのどちらかを選択します。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.24 SecretomeP_DTU 

 

出力ディレクトリと”Organism type”の設定を行います。 

 

1) SecretomeP_DTU ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.24-1 SecretomeP_DTU ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

・Options タブ → Organism type: 

 Gram-negative bacteria、Gram-positive bacteria、Mammalian のどれか

一つを選択します。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.25 DisoPred_AIST 

 

出力ディレクトリの設定を行います。 

 

1) DisoPred_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

5.2.2.25-1 DisoPred_AIST ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.2.2.26 Memsat_AIST 

 

出力ディレクトリの設定を行います。 

 

1) Memsat_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

 5.2.2.26-1 Memsat_AIST ：Configure…  

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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5.3 実行と結果参照 

 

5.3.1 BlastForModeller_AIST → HtmlView 

 

BlastForModeller_AIST の実行結果は、HtmlView ノード上で[ Sequence Similarity 

Report ] として表示します。 

 

 

5.3.1-1 BlastForModeller_AISTの実行結果表示(HtmlView) 
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5.3.2 HitRegionSelector_AIST → HtmlView 

 

HitRegionSelector_AIST の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.2-1 HitRegionSelector_AISTの実行結果表示(HtmlView) 
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5.3.3 TemplateSelector_AIST → PDBjMineWeb 

 

TemplateSelector_AIST の実行結果は、PDBjMineWebノードを実行することで、参

照することができます。 

この参照画面では、ヒット領域ごとに既知の立体構造情報 (PDB コード+チェイン識別

子) のラジオボタン付きリストが表示されます。 

各リストの左側のラジオボタンで選択し、画面下部の Open PDBj Mine Web 

ボタンをクリックすることにより、ブラウザ上に、PDBJサイトの PDBj Mine に登録

された立体構造情報が表示されます。 

 

5.3.3-1 PDBjMineWeb – PDBj Mine 

 

 

5.3.3-2 PDBjMineWeb – PDBj Mine 
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5.3.4 Modeller_AIST → JmolForModeller 

 

Modeller_AISTの実行結果は、JmolForModellerノードを実行することで参照するこ

とができます。 

 

 

 

5.3.4-1 JmolForModeller – Modeller Results 

 

まず、ラジオボタン付きのモデル番号、Objective Function のリストが表示されます(画

面左)。PDBの構造の場合、Objective Function は表示されません。ここで、参照したいモ

デリング結果をラジオボタンで選択し、下部の [ Execute Jmol ] ボタンを押下します。

Jmolが起動すると、選択したモデリング結果の立体構造が表示されます(画面右)。この時、

表示されたモデリング結果を格納したディレクトリ名もポップアップ表示されます(画面

下)。 

右下の Jmol文字列をクリックすることで、Jmolのメニューが表示されます。 

Jmolの操作方法は下記を参照してください。 

Jmol ：http://jmol.sourceforge.net/ 

 

http://jmol.sourceforge.net/
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5.3.5 CPHmodels_DTU → JmolForModeller 

 

CPHmodels_DTU の実行結果は、JmolForModeller ノードを実行することで参照する

ことができます。 

 

 

 

5.3.5-1 JmolForModeller – CPHmodels Results 

 

ラジオボタンが選択されたモデルが一つ表示されます(画面左)。下部の [ Execute 

Jmol ] ボタンを押下すると、Jmolによってモデリング結果が表示されます(画面右)。この

時、表示されたモデリング結果を格納したディレクトリ名もポップアップ表示されます(画

面下)。 

右下の Jmol文字列をクリックすることで、Jmolのメニューが表示されます。 

Jmolの操作方法は下記を参照してください。 

Jmol ：http://jmol.sourceforge.net/ 

 

  

http://jmol.sourceforge.net/
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5.3.6 CPHmodels_DTU → HtmlView 

 

CPHmodels_DTU の実行結果を HtmlView 上でテキスト表示します。 

 

 

5.3.6-1 CPHmodels_DTU の実行結果表示(HtmlView) 
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5.3.7 PsiPred_AIST → AISTViewer 

 

PsiPred_AISTの実行結果は、AISTViewer ノードを実行することで、PSIPRED Result 

として参照することができます。 

 

画面右上の TextViewボタンをクリックすることで、拡大図が別画面で表示されます。 

PSIPRED の詳細については、下記のサイトを参照してください。 

PSIPRED：http://bioinf.cs.ucl.ac.uk/psipred/ 

 

 

5.3.7-1 AISTViewer – PSIPRED Result 

 

http://bioinf.cs.ucl.ac.uk/psipred/


 

69 

 

 

5.3.7-2 PSIPRED Result – TextView 
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5.3.8 Poodle_AIST → AISTViewer 

 

Poodle_AISTの実行結果は、AISTViewer ノードを実行することで、POODLE Result

として参照することができます。 

この参照画面は、POODLE-S、または POODLE-L を実行したディスオーダー予測結

果を、ラインプロット表示します。 

縦軸は 0.0から 1.0までのディスオーダー確率、横軸は残基番号を表します。 

ディスオーダー確率が 0.5の青い線より上の部分、すなわち 0.5以上の部分をディスオ

ーダー領域とします。 

ラインプロットの下の FASTAフォーマットの配列は、予測に使用したアミノ酸配列で

す。 

ディスオーダー予測されたアミノ酸は赤色で表示します。 

 

画面上部の [TextView] ボタンは、POODLE Result の実行結果をテキスト表示する際

に使用します。 

 

 

5.3.8-1 AISTViewer – POODLE Result 
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5.3.8-2 POODLE Result - TextView 
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5.3.9 TmHmm_DTU → HtmlView 

 

TmHmm_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.9-1 TmHmm_DTU の実行結果表示(HtmlView) 
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5.3.10 SignalP_DTU → HtmlView 

 

SignalP_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.10-1 SignalP_DTU の実行結果表示(HtmlView) 
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5.3.11 ChloroP_DTU → HtmlView 

 

ChloroP_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.11-1 ChloroP_DTU の実行結果表示(HtmlView) 
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5.3.12 LipoP_DTU → HtmlView 

 

LipoP_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.12-1 LipoP_DTU の実行結果表示(HtmlView) 
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5.3.13 NetCTL_DTU → HtmlView 

 

NetCTL_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.13-1 NetCTL_DTU の実行結果表示(HtmlView) 
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5.3.14 NetChop_DTU → HtmlView 

 

NetChop_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.14-1 NetChop_DTU の実行結果表示(HtmlView) 
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5.3.15 NetNES_DTU → HtmlView 

 

NetNES_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.15-1 NetNES_DTU の実行結果表示(HtmlView) 
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5.3.16 NetPhosK_DTU → HtmlView 

 

NetPhosK_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.16-1 NetPhosK_DTU の実行結果表示(HtmlView) 
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5.3.17 NetPhos_DTU → HtmlView 

 

NetPhos_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.17-1 NetPhos_DTU の実行結果表示(HtmlView) 
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5.3.18 NetPicoRNA_DTU → HtmlView 

 

NetPicoRNA_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.18-1 NetPicoRNA_DTU の実行結果表示(HtmlView) 
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5.3.19 DictyOGlyc_DTU → HtmlView 

 

DictyOGlyc_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.19-1 DictyOGlyc_DTU の実行結果表示(HtmlView) 
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5.3.20 WolfPsort_AIST → HtmlView 

 

WolfPsort_AISTの実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.20-1 WolfPsort_AISTの実行結果表示(HtmlView) 
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5.3.21 TargetP_DTU → HtmlView 

 

TargetP_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.21-1 TargetP_DTU の実行結果表示(HtmlView) 
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5.3.22 SecretomeP_DTU → HtmlView 

 

SecretomeP_DTU の実行結果を HtmlView ノード上でテキスト表示します。 

 

 

5.3.22-1 SecretomeP_DTU の実行結果表示(HtmlView) 

  



 

86 

 

5.3.23 DisoPred_AIST → AISTViewer 

 

DisoPred_AISTの実行結果は、AISTViewer ノードを実行することで、DISOPRED 

Result として参照することができます。 

ディスオーダー領域は赤色で示されております。 

画面右上の TextViewボタンをクリックすることで、拡大図が別画面で表示されます。 

DISOPRED の詳細については、下記のサイトを参照してください。 

DISOPRED：http://bioinf.cs.ucl.ac.uk/index.php?id=806 

 

 

5.3.23-1 AISTViewer – DISOPRED Result 

 

 

5.3.23-2 DISOPRED Result – TextView  
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5.3.24 Memsat_AIST → AISTViewer 

 

Memsat_AISTの実行結果は、AISTViewerノードを実行することで、MEMSAT Result

として参照することができます。 

膜貫通領域(TM)は赤、膜貫通領域外側のへリックスキャップはマゼンタ、膜貫通領域

内側のへリックスキャップはオレンジ、細胞外のアミノ酸配列はグレー、細胞内のアミノ

酸配列は黒で示されております。 

 

画面上部の [TextView] ボタンは、MEMSAT Result の実行結果をテキスト表示する

際に使用します。 

MEMSATの詳細については、下記のサイトを参照してください。 

MEMSAT：http://bioinf.cs.ucl.ac.uk/software_downloads/memsat/ 

 

5.3.24-1 AISTViewer – Memsat Result 
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5.3.24-2 Memsat Result – TextView 
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6 Phylogenetic Treeの使用方法 

 

Phylogenetic Tree Active ワークフローは、マルチプルアライメント、系統樹作成を行うワ

ークフローです。 

 

Multi-FASTAフォーマットファイルから、Mafftの実行、ClustalWの実行を行います。 

それぞれの結果から Phylogenetic Tree としてビューア上に結果を表示します。 

その他、入力配列から生命科学データベース横断検索(LSDB)を行うことが可能です。 

このワークフローは、各 SOAPサービスを KNIMEのノードとして使用しています。 

 

それぞれのプログラムやデータベースの詳細については、下記のリストより参照してくださ

い。 

名称 サイト 

Mafft http://mafft.cbrc.jp/alignment/software/ 

ClustalW http://www.clustal.org/ 

Archaeopteryx https://sites.google.com/site/cmzmasek/home/software 

/archaeopteryx 

LSDB 

(生命科学データベース)  

http://biosciencedbc.jp/dbsearch/ 

 

 

6-1 Phylogenetic Tree 全体図 
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6.1 実行準備 

 

実行に必要なファイルは、FASTAフォーマットの塩基配列もしくは、アミノ酸配列を

つなげた、Multi-FASTA フォーマットファイルです。 

Phylogenetic Tree の実行には、4本以上の配列を用意してください。 

 

ファイルタイプ 

Multi-FASTA フォーマットファイル 

 

6.2 ノード 

 

Phylogenetic Tree Active Workflow のノードは複数種類存在します。 

ノードは、実行環境の設定が必要な場合があります。 

ノード一覧と、ノードの実行環境設定は以下のとおりです。 

使用するツリーのノードに応じて、設定を行ってください。 

 

6.2.1 ノード一覧 

 

以下の 7種類です。 

 

6.2.1-1 Phylogenetic Tree Active Workflow のノード一覧 

No 名前 アイコン 設

定 

説明 

1  FastaFileReader 

 

要 Multi-FASTAフ

ォーマットファイ

ルを読み込みま

す。 

2  Mafft_AIST 

 

要 Mafftを実行しま

す。 
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3  ClustalW_AIST 

 

要 ClustalWを実行

します。 

4  PhylogeneticTree_AIST 

 

要 PhylogeneticTree

を実行します。 

5  AISTViewer 

 

 予測結果を表示し

ます。 

※ビューア表示は

それぞれ異なりま

す。 

6  PhylogeneticTreeView 

 

 PhylogeneticTree

の実行結果を表示

します。 

7  LSDBCrossSearch 

 

- 生命科学データベ

ース横断検索を表

示します。 
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6.2.2 ノード実行環境設定 

6.2.2.1 FastaFileReader 

 

実行に使用する塩基配列のMulti-FASTAフォーマットファイルを指定します。 

 

1) FastaFileReader ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

 

6.2.2.1-1 FastaFileReader ：Configure… 

 

・Options タブ → Fasta File → SelectedFile: 

図の赤枠内に、実行に使用する Multi-FASTAフォーマットファイルを入力

します。 

  [Browse…] ボタンを押下し、ファイル選択画面を開き、実行に使用する

FASTA フォーマットファイルを選択することも可能です。 

 指定後、[OK] ボタンを押下します。 
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6.2.2.2 ClustalW_AIST 

 

出力ディレクトリの設定を行います。 

 

1) ClustalW_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

  

6.2.2.2-1 ClustalW_AIST ：Configure… 

 

・Options タブ → Type 

入力配列がタンパク質の場合は”PROTEIN”、核酸配列の場合は”DNA”を選択

します。 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

指定後、[OK] ボタンを押下します。 
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6.2.2.3 Mafft_AIST 

 

出力ディレクトリと実行オプションの設定を行います。 

 

1) Mafft_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面を使用します。 

 

  

6.2.2.3-1 Mafft_AIST ：Configure… 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

・Optionsタブ → Advanced → Options 

 実行パラメータを変更する際には、図の青枠内に入力します。 

 パラメータオプションは、スペース区切りで複数指定することができます。

使用可能なオプションは以下の通りです。 
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--op # : Gap opening penalty, default: 1.53   

--ep #  : Offset (works like gap extension penalty), default: 0.0   

--maxiterate # : Maximum number of iterative refinement, default: 0   

--clustalout : Output: clustal format, default: fasta   

--reorder : Outorder: aligned, default: input order   

--quiet  : Do not report progress 

  

デフォルト設定は、以下の通りです。 

--retree 2 --maxiterate 0 --bl 62 --op 1.53 --ep 0.0 --clustalout 

 

指定後、[OK] ボタンを押下します。 

 

6.2.2.4 PhylogeneticTree_AIST 

 

出力ディレクトリと実行オプションの設定を行います。 

 

1) PhylogeneticTree_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面を使用します。 

  

6.2.2.4-1 PhylogeneticTree_AIST ：Configure… 
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・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

・Options タブ → Phylogenetic Tree 

図の青枠内に、実行パラメータを設定します。 

基本的には、デフォルト設定で問題ありません。 

 

・Methods： 

  NJ法か、UPGMA法をラジオボタンで選択します。 

・BOOTSTRAP (valid for “NJ”)： 

  Onか、Offかをラジオボタンで選択します。 

・Number of BOOTSTRAP： 

  ブートストラップ数を設定します。 

  デフォルトは、1000 が設定されています。 

 

 指定後、[OK] ボタンを押下します。 
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6.3 実行と結果参照 

 

6.3.1 ClustalW_AIST → AISTViewer 

 

ClustalW_AISTの実行結果は、AISTViewer ノードを実行することで、ClustalW 

Resultとして参照することができます。 

 入力に使用した配列名が、左側に表示され、その右側に、ClustalWの実行の結果ア

ライメントされた配列が色分け表示されます。 

 上部の [TextView] ボタンは、アライメントに使用している配列を Multi-FASTAフ

ォーマットでテキスト表示を行う際に使用します。 

 

6.3.1-1 AISTViewer – ClustalW Result 
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6.3.1-2 ClustalW Result – TextView 

 

6.3.2 Mafft_AIST → AISTViewer 

  

Mafft_AISTの実行結果は、AISTViewer ノードを実行することで、MAFFT Result

として参照することができます。 

 入力に使用した配列名が、左側に表示され、その右側に、MAFFTの実行の結果アラ

インメントされた配列が色分け表示されます。 

 上部の [TextView] ボタンは、アラインメントに使用している配列を Multi-FASTA

フォーマットでテキスト表示を行う際に使用します。 
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6.3.2-1 AISTViewer – MAFFT Result 

 

 

6.3.2-2 MAFFT Result – TextView 
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6.3.3 PhylogeneticTreeView 

 

PhylogeneticTreeView は、PhylogeneticTree_AISTノードの実行結果を、

Archaeopteryx ビューアを用いて参照することができます。 

PhylogeneticTreeView は ClustalW、Mafftの実行結果を表示します。 

PhylogeneticTreeView では、入力に使用した配列の名称とともに、系統分類を表示

します。 

 

6.3.3-1 PhylogeneticTreeView 

 

PhylogeneticTreeView を一度終了し、再度参照したい場合は、まず、該当する

PhylogeneticTreeView のノードを選択、右クリックメニューから Resetを押下します。

その後再びノードを選択、右クリックメニューから Execute を押下することで、

Archaeopteryx ビューアを再び起動することができます。 
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7 Molecular Simulation の使用方法 

 

Molecular Simulation Active Workflow は、分子シミュレーションを行うワークフローです。

具体的には、タンパク質構造のモデリング、得られたテンプレート構造と、検索してヒットした

化合物とのドッキング、さらにエネルギー最小化計算、分子力学計算 (MM)、分子動力学 (MD) 

計算を行います。 

このワークフローは、モデリング、ドッキング、MD の 3つのセクションから構成されており

ます。まず、問い合わせ配列のタンパク質について、5章と同様の過程でモデリングが行われま

す。次に、モデリングの結果得られた構造をテンプレートとし、AutoDock 

(http://autodock.scripps.edu/)を用いて化合物とのドッキング計算を行います。ドッキングに用

いる化合物について、ナミキ商事で公開されている Namiki (http://www.namiki-s.co.jp/)のデー

タベースを対象に、ユーザが設定した検索条件を基に化合物情報を取得することができます。続

いて、得られたドッキング結果を用いてエネルギー最小化計算、MM計算、MD計算を行いま

す。モデリング構造、ドッキング結果、MM計算結果は、Jmol (http://jmol.sourceforge.net/) に

よって閲覧することができます。 

 

7-1 Molecular Simulation Active Workflow 

  

http://autodock.scripps.edu/
http://www.namiki-s.co.jp/
http://jmol.sourceforge.net/
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7.1 実行準備 

 

実行に必要なファイルは、FASTAフォーマットのアミノ酸配列ファイルです。 

※ FASTAフォーマットをつなげた、Multi-Fastaフォーマットファイルは

利用できません。 

 

ファイルタイプ 

FASTA フォーマットアミノ酸配列ファイル 

 

7.2 ノード 

 

Molecular Simulation Active Workflow のノードは複数種類存在します。 

ノードは、実行環境の設定が必要な場合があります。 

ノード一覧と、ノードの実行環境設定は以下のとおりです。 

使用するツリーのノードに応じて、設定を行ってください。 

 

7.2.1 ノード一覧 

 

以下の 29種類です。 

 

7.2.1-1 Molecular Simulation Active Workflow のノード一覧 

No 名前 アイコン 設

定 

説明 

1 SetVariable 

 

要 CASE Switch 

Variable を操作

する。ダイアロ

グ画面で 0、1、

2を設定すると

CASE Switchの

第一アウトポー

トに、1を設定す

ると第二アウト

ポートにフロー

が流れる。 
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2 CASE Switch 

Variable(Start) 

 

 CASE Switchを

行う KNIMEノ

ード。 

3 FastaFileReader 

 

要 FASTAフォー

マットファイル

を読み込みま

す。 

4 LSDBCrossSearch 

 

- 生命科学データ

ベース横断検索

を表示します。 

5 Sparql_AIST 

 

要 AISTで公開さ

れている

SPARQLエンド

ポイントに対し

て SPARQL検

索を実行しま

す。 

6 SequenceSelector 

 

 SPARQL検索で

取得した配列を

選択します。 

7 CASE Switch 

Variable (End) 

 

 CASE Switchの

エンドノード。 
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8 BlastForModeller_AIST 

 

要 BLASTもしくは

PSI-BLASTを実行

します。 

9 HitRegionSelector_AIST 

 

要 BLASTもしくは

PSI-BLASTの実行

結果より、立体構造

ヒット領域を抽出

します。 

10 TemplateSelector_AIST 

 

要 立体構造モデリン

グのテンプレート

を選択します。 

11 Modeller_AIST 

 

要 MODELLER を実

行します。 

12 DockingTemplateSelector 

 

要 モデリングの結果

から、ドッキングを

行うためのテンプ

レート構造を選択

します。 

13 PdbFileReader 

 

要 PDB ファイルを読

み込みます。 

14 fpocket2_AIST 

 

要 fpocket2 を実行し

ます。 



 

105 

 

15 PocketSelector 

 

 fpocket2 実行結果

からポケットサイ

トを選択します 

16 AutoDock_AIST 

 

要 AutoDockを実行し

ます。 

17 CompoundQuery_AIST 

 

要 化合物検索を実行

します。 

18 CompoundSelector 

 

 化合物検索結果か

ら化合物を選択し

ます。 

19 Mol2FileReader 

 

要 Mol2ファイルを読

み込みます。 

20 Ammos_AIST 

 

要 Ammosを実行しま

す。 

21 MergeTargetAndLigand 

 

 AutoDockの結果と

テンプレート情報

をマージします。 
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22 SiteAndPoseSelector 

 

 ドッキング結果を

指定します。 

23 MMPrep_AIST 

 

要 MM計算のための

準備をします。 

24 InitMinMM_AIST 

 

要 エネルギー最小化

及び MM計算を実

行します。 

25 MoltrecMD_AIST 

 

要 MD 計算を実行し

ます。 

26 End IF 

 

 分岐の終了ノード 

27 ResultPathSetter 

 

要 各予測ノードの結

果を格納したディ

レクトリを指定す

ることにより、結果

を閲覧することが

できます。 

28 HtmlView 

 

 予測結果を表示し

ます。 

※ビューア表示は

それぞれ異なりま

す。 
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29 JmolForModeller 

 

 Jmolを使用したタ

ンパク質立体構造

表示を行います。 
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7.2.2 ノード実行環境設定 

7.2.2.1 SetVariable 

 

CASE Switch Variable (Start)ノードの出力ポートを切り替えます。 

 

1) SetVariable ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

 

7.2.2.1-1 SetVariable ：Configure… 

 

0、1、2の 3つの数字が CASE Switch Variable(Start)ノードの 1～3番目

の出力ポートにそれぞれ対応しております。 FastaFileReaderを使う場合は 0

を、Sparql_AISTを使う場合は 1を指定します。 

  指定後、[Apply]ボタン、[OK] ボタンを押下します。 
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7.2.2.2 FastaFileReader 

 

実行に使用するタンパク質の FASTAファイルを指定します。 

 

1) FastaFileReader ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

 

7.2.2.2-1 FastaFileReader ：Configure… 

 

・Options タブ → Fasta File → SelectedFile: 

図の赤枠内に、実行に使用するFASTAフォーマットファイルを入力します。 

  [Browse…] ボタンを押下し、ファイル選択画面を開き、実行に使用する

FASTA フォーマットファイルを選択することも可能です。 

 指定後、[OK] ボタンを押下します。 
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7.2.2.3 Sparql_AIST 

 

AISTで公開されている SPARQLエンドポイントに対して SPARQL検索を行い

ます。 

 

1) Sparql_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

   

7.2.2.3-1 Sparql_AIST ：Configure… 
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・Options タブ → Output → Selected Directory: 

Sparql_AIST の実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

・Options タブ → SPARQL endpoints: 

SEVENS、fRNAdb、UNIPROT、PDB、KEGG-pathway の 5つのエンド

ポイントをチェックボックスで選択します。本ワークフローでは SEVENS、

UNIPROT、PDBが有効となります。 

 

・Options タブ → SPARQL search conditions: 

タクソン(Taxon)、キーワード(Keyword)、最小配列長(Minimum)、最大配

列長(Maximum)、解像度(Resolution)、パスウェイ(Pathway)を指定します。

本ワークフローではタクソン、キーワード、最小配列長、最大配列長、解像度

が有効です。 

 

・Options タブ → Output format: 

FASTA または Tab-delimited のラジオボタンを指定します。 

 

 

指定後、[OK] ボタンを押下します。 
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7.2.2.4 BlastForModeller _AIST 

 

プログラムの選択と出力ディレクトリの設定を行います。 

 

1) BlastForModeller_AIST ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.4-1 BlastForModeller_AIST ：Configure… 

 

・Options タブ → BLAST version 2.2.18 → Execution Type  

図の赤枠に、Execution Type をラジオボタンで選択します。 

Execution Type は、既存の立体構造のアミノ酸配列との相同性検索を行う

ためのプログラムを、BLASTもしくは PSI-BLAST から選択します。 

 

・Options タブ → BLAST version 2.2.18 → E-Value 

続いて、図の赤枠に、E-value を入力します。 

この E-Value は、BLAST もしくは PSI-BLAST検索において適用される期

待値の閾値となります。 

デフォルトでは、[ 1.0E-5 ] が設定されています。 
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・Options タブ → BLAST version 2.2.18 → Iteration 

続いて、図の赤枠に、Iteration を入力します。 

この Iteration は、PSI-BLASTの最大繰り返し検索回数です。なお、

Execution Type にて BLAST指定時は関与しません。 

デフォルトでは、[ 3 ] が設定されています。 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の青枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 

 

 

7.2.2.5 HitRegionSelector_AIST 

 

BLASTもしくは PSI-BLASTの結果ヒットした配列部の立体構造予測に使用する

条件を設定します。 

 

1) HitRegionSelector_AIST ノードを右クリックし、”Configure…” を選択しま

す。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.5-1 HitRegionSelector_AIST：Configure… 
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・Options タブ → Condition to select (PSI-)BLAST hit regions (Integer is 

only permitted to input) → Coverage(%) 

Coverage を設定します。 

Coverageは、ヒットした立体構造の全長に対するヒット領域の割合であり、

ヒットの基準閾値とするパーセンテージの値です。 

デフォルトでは、[ 60 ] が設定されています。 

数値の入力制限は、以下のとおりです。 

 

・Options タブ → Condition to select (PSI-)BLAST hit regions (Integer is 

only permitted to input) → Identity(%) 

Identity を設定します。 

Identity は、ヒット領域間のアミノ酸の一致度であり、閾値とするパーセン

テージの値です。 

デフォルトでは、[ 30 ] が設定されています。 

数値の入力制限は、以下のとおりです。 

 

・Options タブ → Condition to select (PSI-)BLAST hit regions (Integer is 

only permitted to input) → Minimum Length 

Minimum Length を設定します。 

Minimum Length は、ヒット領域の最小のアミノ酸長の値であり、閾値と

して使用します。 

デフォルトでは、[ 30 ] が設定されています。 

数値の入力制限は、以下のとおりです。 

 

指定後、[OK] ボタンを押下します。 
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7.2.2.6 TemplateSelector_AIST 

 

ヒット領域に対する立体構造モデリングのためのテンプレートを設定します。 

 

1) TemplateSelector_AIST ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.6-1 TemplateSelector_AIST：Configure… 

 

・Options タブ → Condition to determine for modelling or for displaying 

PDBj Mine Web. → Coverage(%), Identity(%) 

Coverate、Identity の値を設定します。 

Coverage は、ヒットした立体構造の全長に対するヒット領域の割合です。 

Identity は、ヒット領域間のアミノ酸の一致度です。 

この２つの値は、ヒットした立体構造と同様の構造を持つことの判定に用い

ます。指定した値を超えるヒット領域については、そのヒット領域はヒットし

た立体構造と同様であるとみなされ、PDBj Mine による立体構造情報表示の

処理に入ります。指定した値を満たさないヒット領域については、モデリング

のテンプレートとする立体構造を選択してモデリングの処理に入ります。 

デフォルト値は、Coverage 90 %、Identity 90 % です。 

整数値のみ入力が可能です。 

 

指定後、[OK] ボタンを押下します。 
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7.2.2.7 Modeller_AIST 

 

MODELLER で生成するモデル数の最大値を設定と、MODELLER のライセンス

キーの入力を行います。 

 

1) Modeller_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.7-1 Modeller_AIST：Configure… 

 

・Options タブ → Condition for Modeller Execution → Number of Models 

for Modelling 

Number of Models for Modelling を入力します。 

Number of Models for Modelling は、MODELLER で生成するモデル数の

最大値として使用します。 

入力範囲は、 1～10 であり、整数値のみの入力が可能です。 

 

・Options タブ → Modeller License → License Key for Modeller 

(required) 

License Key for Modeller (required)では、MODELLER 実行のためのライ

センスキーを入力します。 

設定後、[OK] ボタンを押下します。 
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7.2.2.8 CompoundQuery_AIST 

 

化合物の検索条件を設定します。 

 

1) CompoundQuery_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面に、実行環境を設定します。 

 

7.2.2.8-1 CompoundQuery_AIST ：Configure… 
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・Options タブ 

Database: 

Namikiが選択されています。 

Search Words: 

検索するキーワードを入力します。使用する場合はチェックボックスをチェッ

クします。 

Molecular Weight: 

分子量の範囲を指定します(デフォルトは 300.0～305.0)。使用する場合はチェ

ックボックスをチェックします(デフォルトでチェック)。 

logP: 

logPの範囲を指定します(デフォルトは 1.0～2.0)。使用する場合はチェックボ

ックスをチェックします(デフォルトでチェック)。 

TPSA: 

TPSAの範囲を指定します(デフォルトは 80.0～140.0)。使用する場合はチェ

ックボックスをチェックします。 

smiles: 

smilesを入力します。使用する場合はチェックボックスをチェックします。 

inchi: 

inchi を入力します。使用する場合はチェックボックスをチェックします。 

inchikey: 

inchikey を入力します。使用する場合はチェックボックスをチェックします。 

Number of rotatable bonds: 

rotatable bond の範囲を指定します(デフォルトは 3～7)。使用する場合はチェ

ックボックスをチェックします。 

Charge: 

Charge の範囲を指定します(デフォルトは 0～2)。使用する場合はチェックボ

ックスをチェックします。 

H-bond Acceptor: 

H-bond Acceptor の範囲を指定します(デフォルトは 3～8)。使用する場合はチ

ェックボックスをチェックします。 

H-bond Donor: 

H-bond Donorの範囲を指定します(デフォルトは 8～8)。使用する場合はチェ

ックボックスをチェックします。 

Number of rings: 

ring の範囲を指定します(デフォルトは 1～5)。使用する場合はチェックボック

スをチェックします。 
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Search Condition: 

検索条件”AND”、”OR”のどちらかを指定します(デフォルトは”AND”)。 

 

次に、出力結果を格納するディレクトリを指定します。 

 

  

7.2.2.8-2 CompoundQuery_AIST ：Configure…続き 

 

・Options タブ → Select Output Directory → Selected Directory: 

図の赤枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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7.2.2.9 AutoDock_AIST 

 

出力ディレクトリの設定を行います。 

 

1) AutoDock_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.9-1 AutoDock_AIST ：Configure… 

 

・Options タブ → XYZ-coordinate 

図の赤枠の箇所に、XYZ座標を指定します。 

・Options タブ → Select Output Directory → Selected Directory: 

図の青枠内に、実行結果を出力するディレクトリを入力します。 

  [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用す

るディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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7.2.2.10 MMPrep_AIST 

 

出力ディレクトリの設定を行います。 

 

1) MMprep_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.10-1 MMPrep_AIST ：Configure… 

 

・Options タブ → Output → Selected Directory： 

Output欄に、実行結果を出力するディレクトリを入力します。 

 [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用

するディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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7.2.2.11 InitMinMM_AIST 

 

出力ディレクトリの設定を行います。 

 

1) InitMinMM_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.11-1 InitMinMM_AIST ：Configure… 

 

・Options タブ → Output → Selected Directory： 

Output欄に、実行結果を出力するディレクトリを入力します。 

 [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用

するディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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7.2.2.12 MoltrecMD_AIST 

 

出力ディレクトリの設定を行います。 

 

1) MoltrecMD_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.12-1 MoltrecMD_AIST ：Configure… 

 

・Options タブ → Output → Selected Directory： 

Output欄に、実行結果を出力するディレクトリを入力します。 

 [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用

するディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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7.2.2.13 ResultPathSetter 

 

以前に実行した KNIMEノードの結果が格納されたディレクトリ、その KNIME

ノード名、問い合わせ配列名(Poodle_AIST、PsiPred_AISTのみ)の設定を行いま

す。 

 

1) ResultPathSetter ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.13-1 ResultPathSetter ：Configure… 

 

・Options タブ 

Selected Directory： 

以前に実行した KNIMEノードの結果を格納したディレクトリを入力し

ます。 

[Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用

するディレクトリを選択することも可能です。 

 

KNIME nodes： 

実行した KNIMEノード名を選択します。 

Sequence Name：(Poodle_AIST、PsiPred_AISTのみ) 

結果画面に表示するための問い合わせ配列名を選択します。 

指定後、[OK] ボタンを押下します。 
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7.2.2.14 Ammos_AIST 

 

出力ディレクトリの設定を行います。 

 

1) Ammos_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.14-1 Ammos_AIST ：Configure… 

 

・Options タブ → Output → Selected Directory： 

Output欄に、実行結果を出力するディレクトリを入力します。 

 [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用

するディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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7.2.2.15 fpocket2_AIST 

 

出力ディレクトリの設定を行います。 

 

1) fpocket2_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.15-1 fpocket_AIST ：Configure… 

 

・Options タブ → Output → Selected Directory： 

Output欄に、実行結果を出力するディレクトリを入力します。  

 [Browse…] ボタンを押下し、ディレクトリ選択画面を開き、出力に使用

するディレクトリを選択することも可能です。 

 

指定後、[OK] ボタンを押下します。 
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7.2.2.16 PdbFileReader 

 

実行に使用する PDBエントリフォーマットの ATOMファイルを指定します。 

 

1) PdbFileReader ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.16-1 PdbFileReader ：Configure… 

 

・Options タブ → PDB File → SelectedFile: 

図の赤枠内に、実行に使用する PDBファイルを入力します。 

  [Browse…] ボタンを押下し、ファイル選択画面を開き、実行に使用する

PDB ファイルを選択することも可能です。 

 指定後、[OK] ボタンを押下します。 
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7.2.2.17 Mol2FileReader 

 

実行に使用する Mol2フォーマットファイルを指定します。 

 

1) Mol2FileReader ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

7.2.2.17-1 Mol2FileReader ：Configure… 

 

・Options タブ → MOL2 File → SelectedFile: 

図の赤枠内に、実行に使用する Mol2ファイルを入力します。 

  [Browse…] ボタンを押下し、ファイル選択画面を開き、実行に使用する

Mol2ファイルを選択することも可能です。 

指定後、[OK] ボタンを押下します。 
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7.3 実行と結果参照 

 

7.3.1 BlastForModeller_AIST → HtmlView 

 

BlastForModeller_AIST に接続している HtmlView では、BlastForModeller_AISTの

実行結果を、[ Sequence Similarity Report ] として表示します。 

 

 

7.3.1-1 BlastForModeller_AISTの実行結果表示(HtmlView) 
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7.3.2 HitRegionSelector_AIST → HtmlView 

 

HitRegionSelector_AIST に接続している HtmlView では、HitRegionSelector_AIST

の実行結果をテキスト表示します。 

 

 

7.3.2-1 HitRegionSelector_AISTの実行結果表示(HtmlView) 
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7.3.3 TemplateSelector_AIST → PDBjMineWeb 

 

TemplateSelector_AIST の実行結果は、PDBjMineWebノードを実行することで、参

照することができます。 

この参照画面では、ヒット領域ごとに既知の立体構造情報 (PDB コード+チェイン識別

子) のラジオボタン付きリストが表示されます。 

各リストの左側のラジオボタンで選択し、画面下部の Open PDBj Mine Web 

ボタンをクリックすることにより、ブラウザ上に、PDBJサイトの PDBj Mine に登録

された立体構造情報が表示されます。 

 

7.3.3-1 PDBjMineWeb – PDBj Mine 

 

 

7.3.3-2 PDBjMineWeb – PDBj Mine 
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7.3.4 Modeller_AIST → JmolForModeller 

 

Modeller_AISTの実行結果は、JmolForModellerノードを実行することで参照するこ

とができます。 

 

 

 

7.3.4-1 JmolForModeller – Modeller Results 

 

まず、ラジオボタン付きのモデル番号、Objective Function のリストが表示されます(画

面左)。PDBの構造の場合、Objective Function は表示されません。ここで、参照したいモ

デリング結果をラジオボタンで選択し、下部の [ Execute Jmol ] ボタンを押下します。

Jmolが起動すると、選択したモデリング結果の立体構造が表示されます(画面右)。この時、

表示されたモデリング結果を格納したディレクトリ名もポップアップ表示されます(画面

下)。 

右下の Jmol文字列をクリックすることで、Jmolのメニューが表示されます。 

Jmolの操作方法は下記を参照してください。 

Jmol ：http://jmol.sourceforge.net/ 

 

  

http://jmol.sourceforge.net/
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7.3.5 AutoDock_AIST → JmolForModeller 

 

AutoDock_AISTの実行結果は、JmolForModeller ノードを実行することで参照するこ

とができます。 

 

 

  

 

7.3.5-1 JmolForModeller – Results 

 

まず、上画面のドッキングサイトごとの結果画面が表示されます(XYZ座標を指定した

場合、”Site 1”のみ表示されます)。この画面から、参照したい各ドッキング画像の下部に

ある”Site”ボタンをクリックすると、ラジオボタン付きの化合物 - Energy リスト画面が

開きます(左画面)。ここで、Jmolで起動したいドッキング結果をラジオボタンで選択し、
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下部の [ Execute Jmol ] ボタンを押下します。選択したドッキング結果の立体構造(右画

面)及び結果格納ディレクトリ名表示ポップアップ(下画面)が表示されます。 

右下の Jmol文字列をクリックすることで、Jmolのメニューが表示されます。 

Jmolの操作方法は下記を参照してください。 

Jmol ：http://jmol.sourceforge.net/ 

  

http://jmol.sourceforge.net/
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7.3.6  InitMinMM_AIST → JmolForModeller 

 

InitMinMM_AISTの実行結果は、JmolForModeller ノードを実行することで参照する

ことができます。 

 

 

 

7.3.6-1 JmolForModeller –Results 

 

まず、ラジオボタン付きのモデル番号、Scoreのリストが表示されます(画面左)。ここ

で、参照したいモデリング結果をラジオボタンで選択し、下部の [ Execute Jmol ] ボタン

を押下します。Jmolが起動すると、選択した結果の立体構造が表示されます(画面右)。こ

の時、表示された結果を格納したディレクトリ名もポップアップ表示されます(画面下)。 

右下の Jmol文字列をクリックすることで、Jmolのメニューが表示されます。 

Jmolの操作方法は下記を参照してください。 

Jmol ：http://jmol.sourceforge.net/ 

 

  

http://jmol.sourceforge.net/
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7.3.7  MoltrecMD_AIST → HtmlView 

 

MoltrecMD_AISTの実行結果は、HtmlView ノードを実行することで参照することが

できます。 

 

MD 計算のスコアがモデルごとに表示されます。 

 

7.3.7-1 HtmlView – Results 

 

7.3.8 ResultPathSetter → JmolForModeller、HtmlView 

 

ResultPathSetter の実行結果は、JmolForModellerノードもしくは HtmlView ノード

を実行することで参照することができます。ResultPathSetter で指定した KNIMEノー

ドに対応した結果画面が表示されます(7.3.1～7.3.7と同様の結果画面)。 
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7.3.9  fpocket2_AIST → JmolForModeller 

 

fpocket2_AISTの実行結果は、JmolForModellerノードを実行することで参照するこ

とができます。 

 

 

 

 

7.3.9-1 JmolForModeller –Results 

 

まず、ラジオボタン付きのリストが表示されます(画面上左)。ここで、下部の [ Execute 

Jmol ] ボタンを押下します。Jmolが起動すると、選択した結果の立体構造が表示されます

(画面上右)。この時、立体構造のポケットサイトの座標画面(画面下左)、表示された結果を

格納したディレクトリ名もポップアップ表示されます(画面下右)。 

右下の Jmol文字列をクリックすることで、Jmolのメニューが表示されます。 

Jmolの操作方法は下記を参照してください。 

Jmol ：http://jmol.sourceforge.net/ 

  

http://jmol.sourceforge.net/
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8 SPARQLノードの使用方法 

 

SPARQLノードは、SPARQLを実行するノードであり、2つの種類があります。 

 

8.1 ノード 

 

8.1.1 ノード一覧 

 

以下に 2種類の SPARQL ノード、及び関連するノード 2種類を示します。 

 

8.1.1-1 SPARQLノード一覧 

No 名前 アイコン 設

定 

説明 

1  Sparql_AIST 

 

要 AIST公開のエン

ドポイントに対

し、簡単なキーワ

ード指定で

SPARQLを実行

します。 

2  Sparql_AIST_Adv 

 

要 公開されたエンド

ポイントに対し、

SPARQL検索を

実行します。 

3  SequenceSelector 

 

 SPARQLの実行

結果をポップアッ

プ表示し、指定し

た配列ファイルを

生成します。 

4  HtmlView 

 

 SPARQLの実行

結果を表示しま

す。 
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8.1.2  Sparql_AIST ノード 

8.1.2.1 実行環境設定 

 

1) Sparql_AISTノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

8.1.2.1-1 Sparql_AIST ：Configure… 
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8.1.2.1-2 Sparql_AIST ：Configure… 

 

・Options タブ → Output Directory: 

図の赤枠内に、SPARQLの実行結果を格納するディレクトリを指定します。 

 

・Options タブ → SPARQL Endpoints: 

図の青枠内から、使用する SPARQL endpoint を指定・入力します。検索対

象は SEVENS、fRNAdb、UNIPROT、PDB、KEGG-pathway となります。

複数の endpointの指定が可能です。 

 

・Options タブ → SPARQL search conditions: 
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図の緑枠内に、SPARQL の検索条件を入力します。検索条件には、1)生物

種検索(Taxon、UNIPROT、KEGG-pathway以外の endpoint で利用可)、2)

キーワード検索(KEGG-pathway 以外の endpointで利用可)、3)配列長検索(最

大配列長、最小配列長、KEGG-pathway 以外の endpoint で利用可)、4)解像

度(Resolution、PDBの endpoint のみ利用可)、5)パスウェイ(Pathway、

KEGG-pathway のみ利用可)があります。 

 

・Options タブ → Output format: 

図の橙枠内から、FASTA あるいは Tab-limited のどちらかを選択します。

FASTA を選択した場合、SPARQL実行結果が FASTA フォーマットファイル

として生成され、Tab-limited を選択した場合はタブ区切りのテキストファイ

ルとして生成されます。SequenceSelector ノードを利用して配列選択を行う

場合は FASTAを選択してください。 

 

・Advanced タブ: 

SPARQL文を入力します。もしこのテキストフィールドに SPARQL文が入力

された場合、上記で設定した”SPARQL search conditions”は無視されます。 

  指定後、[OK] ボタンを押下します。 
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8.1.3  Sparql_AIST_Advノード 

8.1.3.1 実行環境設定 

 

1) Sparql_AIST_Adv ノードを右クリックし、”Configure…” を選択します。 

 

2) ポップアップで別画面表示されるダイアログ画面で設定します。 

  

8.1.3.1-1 Sparql_AIST_Adv ：Configure… 

 

 

・Options タブ → Output Directory: 

図の赤枠内に、SPARQLの実行結果を格納するディレクトリを指定します。 

 

・Options タブ → SPARQL Endpoints: 

図の青枠内から、使用する SPARQL endpoint を入力します。 

 

・Options タブ → Input SPARQL Query: 

図の緑枠内に、SPARQL 文を入力します。 

 指定後、[OK] ボタンを押下します。 
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8.1.4  SequenceSelector ノード 

8.1.4.1 実行結果 

SequenceSelector ノードのアイコンを右クリックして Executeを選択するすると、

SequenceSelector ノードが実行され、SPARQLの実行結果が表示されます。この

ノードは、Sparql_AISTノードにおいて FASTAフォーマットでの SPARQL検索

を行った場合に利用可能となります。 

 

8.1.4.1-1 SequenceSelector 実行結果 

 

一つの配列情報を選択することが可能であり、Submitボタンをクリックすると

SequenceSelector ノードの out portに選択した配列の FASTAフォーマットファ

イルが設定されます。この out port を配列解析ノードの in portに接続することに

より、各種配列解析を行うことが可能です。 
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8.1.5  HtmlViewノード 

8.1.5.1 実行結果 

HtmlView ノードのアイコンを右クリックして Execute を選択するすると、

HtmlView ノードが実行されます。このノードは、Sparql_AIST、

Sparql_AIST_Adv の各ノードにおいて行った SPARQL検索の結果を表示するこ

とができます。 

 

8.1.5.1-1 HtmlView 実行結果 
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9 付録 

9.1 付録 A：LSDBCrossSearch 

 

LSDBCrossSearch ノードが実行完了後、緑色表示の場合に、生命科学データベース横断検

索を実行することができます。 

生命科学データベース横断検索サイトは、文部科学省 統合データベースプロジェクトにお

いて開発されました。 

LSDBCrossSearch ノードを選択し、右クリックを押下、表示メニューから “View: name of 

first view” を選択すると、LSABCrossSearch ノードの View画面が表示されます。 

 

 

9.1-1 LSDBCrossSearch View 画面 

 

FASTA Header Lists には、LSDBCrossSearch ノードの入力に使用した FASTA ファイ

ルのヘッダ行が表示されます。 

LSDB Cross Search のテキストボックスには、横断検索を実行するためのキーワードを入

力します。 
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キーワードの複合検索を行う場合は、以下の検索記号を使用します。 

・AND 検索 ：スペース “  “ 

・OR 検索 ：パイプ“ | “ 

・排他的論理和検索 ：エクスクラメーションマーク“ ! “ 

・ワイルドカード検索 ：アスタリスク“ * “ 

 

なお、検索では OR 検索が優先されます。 

キーワードを入力後、LSDB Cross Search ボタンをクリックすると、生命科学データベー

ス横断検索の Web ブラウザが開き、横断検索が実行されます。 

 

 

 

 

詳細は、下記の生命科学データベース横断検索サイトより HELPを参照してください。 

生命科学データベース横断検索サイト：http://biosciencedbc.jp/dbsearch/ 

 

  

http://biosciencedbc.jp/dbsearch/
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10 おわりに 

 

ご質問やご意見は下記のメールアドレスにお願いいたします。 

workflow@molprof.jp  

 

 

産業技術総合研究所 創薬分子プロファイリング研究センター 情報統合班では、

利用者のご要望を積極的に取り入れ、より良いシステムにしていく計画です。  

 

 

産業技術総合研究所  

創薬分子プロファイリング研究センター  

情報統合班 http://togo.medals.jp 

 

〒135-0064 東京都江東区青海 2-4-7 

産総研 臨海副都心センター別館（バイオ・IT融合研究棟）  

 

mailto:workflow@molprof.jp

